SSL-Verschlüsselung für WordPress in einer Minute aktivieren

SSL schützt die Datenübertragung zwischen Ihrer Website und Ihren Besuchern durch Verschlüsselung. Das schafft Sicherheit, Vertrauen und ein besseres Ranking in Suchmaschinen.

Wir möchten, dass SSL für Ihre Websites einfach selbstverständlich ist. Deshalb können Sie SSL für Ihre Managed WordPress-Website bei uns kostenlos mit nur drei Klicks aktivieren:

SSL für WordPress - SSL im 1&1 App-Center aktivieren

So einfach geht’s

Im 1&1 App-Center können Sie SSL-Verschlüsselung für Ihre Website mit unserem Assistenten aktivieren:

  1. SSL aktivieren
  2. Richtlinien akzeptieren
  3. Kostenlos aktivieren

SSL-Verschlüsselung schützt jetzt Ihre Website!


SSL kostenlos aktivieren

SSL wird automatisch konfiguriert

Alle Anpassungen an Ihrer Domain und in WordPress übernehmen wir für Sie. Verwenden Sie Ihre Website einfach wie gewohnt weiter!

Ihre Besucher werden automatisch auf die sichere HTTPS-Verbindung umgeleitet und profitieren so immer von 256-Bit SSL-Verschlüsselung. Favoriten und Links auf Ihre Website, die http:// statt https:// verwenden, funktionieren durch die automatische Umleitung (Redirect) weiterhin ohne Einschränkung.


Falls Sie mehr über SSL erfahren möchten, besuchen Sie unsere SSL-Themenseite oder die SSL-Übersichtsseite auf 1und1.de.

Das könnte Sie auch interessieren

Diesen Beitrag bewerten:

15 Gedanken zu „SSL-Verschlüsselung für WordPress in einer Minute aktivieren

  1. Ich habe für die o.a. Website Managed-Wordpress. Die SSL Verschlüsselung habe ich leider nicht wie oben beschrieben, sondern unter der Rubrik SSL-Zertifikate aktiviert. Jetzt kann ich nicht mehr auf das Managed WordPress Dashboard zugreifen. Der Weg der Verschlüsseldung über die Rubrik SSL-Zertifikate kann nicht mehr rückgägnig gemacht werden und ist auch nicht unter der Möglichkeit der Kündigung des Vertragsbestandteils aufgelistet.
    Selbst das Anlegen einer Subdomain und das Verschieben des SSL-Zertifikates auf die Subdomain hat nicht geholfen.
    Was kann ich tun? Ich will auf jeden Fall diese SSL-Starter Zertifizierung rückgängig machen!
    MfG
    Joachim Trautmann

    1. 1und1hilfe sagt:

      Hallo Herr Trautmann,

      die Probleme, die ihre Zertifikate aktuell machen, kann ich nachvollziehen und habe den Fall gerade an die zuständigen Techniker weitergegeben.

      Ihre WordPress-Installation sollte dies jedoch nicht beeinträchtigen, da Sie dort ja noch alles via http und nicht mit https hinterlegen haben.

      Sollten Sie weiterhin nicht in Ihr WordPress-Dashboard kommen,
      senden Sie mir gerne weiterführende Infos per E-Mail an hilfe@1und1.de

      Vielen Dank und Grüße,
      Michael, 1&1

  2. Hallo Michael,

    vielen Dank für die Info. Ich komme jetzt erst wieder dazu mich weiter mit dem Thema zu beschäftigen.

    Ich habe den Zugriff auf das Dashboard wieder hergestellt indem ich den SSLStarter auf eine Subdomain verschoben habe. Seitdem funktioniert aber die Anzeige des RSS-Feed als Widget nicht mehr so, wie es vorher war (Verlinkungen auf die neuesten 10 Beiträge). Ich habe vermutet, dass dies noch mit dem SSL-Starter zusammenhängt und deshalb habe ich versucht den wieder auf eine ungenutzte Einstellung zu bringen, indem ich die Subdomain geschlöscht habe. An der Einstellung für den SSL-Starter hat das nichts geändert (der steht nach wie vor aktiv auf einer jetzt gelöschten Subdomain), aber so konnten dann wieder die RSS-Feeds, wenn auch nur als genereller Link und nicht auf die einzelnen Beiträge, im Widget wieder angezeigt werden.

    Übrigens, die Anzeige im 1&1 App-Center, wie oben in der Grafik, habe ich nie gehabt. SSL-Starter stand nur im 1&1 Control-Center unter SSL-Zertifikate und dort habe ich dann den SSL-Starter auch aktiviert bzw. dann später nach den Problemen auf eine Subdomain umgeleitet.

    Für einen Tipp, wie ich das korrekt hinbekomme, entweder hier (vielleicht gibt es ja noch mehr Leute die Probleme haben) oder über eine Nachricht an meine Mailadresse wäre ich sehr dankbar.

    Vielen Dank und Grüße,
    Joachim

    1. 1und1hilfe sagt:

      Hallo Joachim,

      das oben im Artikel beschriebene Feature gibt es zur Zeit nur in neuen Webhosting / Managed WP-Tarifen. Neu bedeutet in diesem Fall: Ab dem 10.05.2016 abgeschlossen.

      Viele Grüße,
      Michael, 1&1

  3. Christoph sagt:

    Ich habe auf unserer Webseite das SSL Zertifikat installiert. Die Domain https://wortmalereien.com wird jedoch als “Verbindung ist nicht sicher” (gelbes Schloss) angezeigt.

    Wenn ich mir den Unterschied zwischen HTTP und HTTPS anschaue, so sehe ich, dass bei der HTTPS Verbindung das Logo (WM_Logo_165x60.png) nicht angezeigt wird. Ferner wird die Seite nicht automatisch in HTTPS angesteuert. In Anbetracht dessen, dass bei HTTPS das Bild-Logo nicht angezeigt wird ist es OK.

    Dennoch stelle ich mir die Frage, wie können wir automatisch die Seite in HTTPS öffnen und das Logo (PNG Bild) behalten.

    Mit herzlichen Grüßen
    Christoph

    1. 1und1hilfe sagt:

      Hallo Christoph,

      genau zu diesem Thema haben wir in den letzten Tagen einen Artikel veröffentlicht: https://community.1und1.de/mixed-content-erkennen-und-entfernen/

      Was ihre Bilddatei fürs Logo angeht, so finde ich hierzu diese URL-Angabe:

      https: // s646224018.online.de/wp-content/uploads/2013/11/WM_Logo_165x60.png

      Ein Zertifikat haben Sie aber nur für Ihre “richtige” Domain, nicht für diese Standard-Subdomain. Das Ändern der Pfadangabe von http in https ist hier also nicht so einfach möglich.

      Das Logo müssten Sie richtigerweise mit dieser URL einbinden (ohne die Leerzeichen nach dem https, diese hab ich nur eingebaut, damit unser Kommentarsystem das einigermaßen sinnvoll darstellt):

      https: // wortmalereien.com/wp-content/uploads/2013/11/WM_Logo_165x60.png

      Warum Ihre Website beim Start nicht “grün” als SSL verschlüsselt angezeigt wird, liegt am oben schon erwähnten Mixed Content. Ich hab mir das mal in der Netzwerk-Analyse von Chrome angesehen. Dort finde ich dann z.B. dieses hier:

      “(index):254 Mixed Content: The page at ‘https: // wortmalereien.com/’ was loaded over HTTPS, but requested an insecure image ‘http : // s646224018.online.de/wp-content/uploads/2013/12/AndreaMaier_hp.gif’. This content should also be served over HTTPS.”

      Die Subdomain dürfte noch irgendwo in Ihrem WordPress (evtl. in der MySQL-Datenbank oder auch durch Angabe im Code einer Theme-Datei) so angegeben sein. Das sollten Sie dann entsprechend ändern.

      Viele Grüße,
      Michael, 1&1

  4. Christoph sagt:

    Hallo Michael,
    vielen herzlichen Dank für diese wertvollen Informationen.

    Das Beste wird es wohl sein, die Datenbank zu sichern und dann mit “Better Search Replace”, oder “Database Search und Replace” die fehlerhaften Links zu ersetzen. Vor allem, alle Links in HTTPS zu wandeln und dann ein Redireckt in der .htaccess zu setzen.

    Sie haben mir bestens geholfen.
    Herzliche Grüße
    Christoph

  5. Christoph sagt:

    Alles hat bestens geklappt! 🙂

    Vielen Dank!
    Christoph

    1. 1und1hilfe sagt:

      Super, das freut uns 🙂

      Sehr gern geschehen!
      Michael, 1&1

  6. Hagen sagt:

    “SSL wird automatisch konfiguriert
    Alle Anpassungen an Ihrer Domain und in WordPress übernehmen wir für Sie.”

    stimmt nicht: mixed content muss selbst entfernt werden und anschliessend zeigen die permalinks immer noch auf http, die wpconfig und die htaccess können nicht angepasst werden, weder per ftp noch per wordpress, dadurch kann auch keine automatische weiterleitung von http auf https eingerichtet werden

    1. 1und1hilfe sagt:

      Hallo Hagen,

      im Normalfall klappt das tatsächlich automatisch. Gerne prüfen und beheben wir Ihre Probleme mit dem mixed Content in Ihrer Managed WordPress Installation. Senden Sie uns dazu einfach Ihre Vertragsdaten + die WordPress URL per E-Mail an hilfe@1und1.de

      Viele Grüße,
      Michael, 1&1

  7. Stephan sagt:

    Sie erklären in Ihrem, dass es sehr einfach ist, ein managed WordPress mit SSL zum Laufen zu bringen. Kann ich irgendwo nachlesen, wie man ein WordPress, das ich manuell auf dem Server installiert habe, mit SSL zum Laufen bringt?
    Viele Grüße
    Stephan

    1. 1und1hilfe sagt:

      Hallo Stephan,

      da WordPress kein integriertes SSL-Feature hat, welches man einfach ein- oder ausschalten könnte, ist die Vorgehensweise wie bei einem Domain-Wechsel. Hier erklären wir Ihnen die einzelnen Schritte: https://hilfe-center.1und1.de/hosting/1und1-webhosting-c10085285/websites-erstellen-und-bearbeiten-c10082635/app-center-c10082695/domain-wechseln-bei-wordpress-standard-a10794733.html

      Ggf. ist es noch erforderlich, Anpassungen direkt in der MySQL-Datenbank vorzunehmen. Hierzu finden Sie hier eine Anleitung: https://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

      Viele Grüße,
      Michael, 1&1

  8. Birgit sagt:

    Hallo,

    seit rund einem halben Jahr lebe ich in dem Glauben, meine Website sei sicher, da ich SSL aktiviert hatte. Nun stelle ich fest, dass man es noch umständlich einrichten muss. Die eine Minute ist jetzt schon mindestens 250-fach abgelaufen.

    Ich habe die .htaccess im 1&1 Webexplorer gesehen. WordPress meldet mir in Abschnitt Permalinks, dass sie leider nicht writable war, deshalb solle man folgenden Code einfügen:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Den Code habe ich in eine neue Datei geschrieben (Editor). Beim Transfer mit WinSCP war die Datei offensichtlich unsichtbar, also habe ich meine neu .htaccess in das Root-Verzeichnis kopiert – in der Hoffnung, dass die alte Datei überschrieben wird. Denn Umbenennen, Sichtbarmachen, Runterladen und Verschieben ging genausowenig wie das Öffnen.
    Mit Better Search Replace habe ich alle http:// in https:// umgewandelt, und zwar vor und nach dem FTP-Transfer.
    Jetzt läuft die Sache immer noch nicht und ich bin ABSOLUT ratlos.

    Haben Sie noch einen Tipp?

    Viele Grüße
    Birgit Bruder

    1. 1&1 Hosting Support sagt:

      Hallo,

      wie ich sehen konnte, konnten die Kollegen bereits helfen. Im Managed Mode gibt es leider keinen Schreibzugriff auf die .htaccess-Datei, weshalb hier zum Standard Mode gewechselt werden muss. Damit ist es dann kein Problem mehr.

      Viele Grüße
      Martin, 1&1

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *