SSL-Verschlüsselung für WordPress in einer Minute aktivieren

SSL schützt die Datenübertragung zwischen Ihrer Website und Ihren Besuchern durch Verschlüsselung. Das schafft Sicherheit, Vertrauen und ein besseres Ranking in Suchmaschinen.

Wir möchten, dass SSL für Ihre Websites einfach selbstverständlich ist. Deshalb können Sie SSL für Ihre Managed WordPress-Website bei uns kostenlos mit nur drei Klicks aktivieren:

SSL für WordPress - SSL im 1&1 App-Center aktivieren

So einfach geht’s

Im 1&1 App-Center können Sie SSL-Verschlüsselung für Ihre Website mit unserem Assistenten aktivieren:

  1. SSL aktivieren
  2. Richtlinien akzeptieren
  3. Kostenlos aktivieren

SSL-Verschlüsselung schützt jetzt Ihre Website!


SSL kostenlos aktivieren

SSL wird automatisch konfiguriert

Alle Anpassungen an Ihrer Domain und in WordPress übernehmen wir für Sie. Verwenden Sie Ihre Website einfach wie gewohnt weiter!

Ihre Besucher werden automatisch auf die sichere HTTPS-Verbindung umgeleitet und profitieren so immer von 256-Bit SSL-Verschlüsselung. Favoriten und Links auf Ihre Website, die http:// statt https:// verwenden, funktionieren durch die automatische Umleitung (Redirect) weiterhin ohne Einschränkung.


Falls Sie mehr über SSL erfahren möchten, besuchen Sie unsere SSL-Themenseite oder die SSL-Übersichtsseite auf 1und1.de.

Das könnte Sie auch interessieren

Diesen Beitrag bewerten:

70 Gedanken zu „SSL-Verschlüsselung für WordPress in einer Minute aktivieren

  1. Ich habe für die o.a. Website Managed-Wordpress. Die SSL Verschlüsselung habe ich leider nicht wie oben beschrieben, sondern unter der Rubrik SSL-Zertifikate aktiviert. Jetzt kann ich nicht mehr auf das Managed WordPress Dashboard zugreifen. Der Weg der Verschlüsseldung über die Rubrik SSL-Zertifikate kann nicht mehr rückgägnig gemacht werden und ist auch nicht unter der Möglichkeit der Kündigung des Vertragsbestandteils aufgelistet.
    Selbst das Anlegen einer Subdomain und das Verschieben des SSL-Zertifikates auf die Subdomain hat nicht geholfen.
    Was kann ich tun? Ich will auf jeden Fall diese SSL-Starter Zertifizierung rückgängig machen!
    MfG
    Joachim Trautmann

    1. 1und1hilfe sagt:

      Hallo Herr Trautmann,

      die Probleme, die ihre Zertifikate aktuell machen, kann ich nachvollziehen und habe den Fall gerade an die zuständigen Techniker weitergegeben.

      Ihre WordPress-Installation sollte dies jedoch nicht beeinträchtigen, da Sie dort ja noch alles via http und nicht mit https hinterlegen haben.

      Sollten Sie weiterhin nicht in Ihr WordPress-Dashboard kommen,
      senden Sie mir gerne weiterführende Infos per E-Mail an hilfe@1und1.de

      Vielen Dank und Grüße,
      Michael, 1&1

  2. Hallo Michael,

    vielen Dank für die Info. Ich komme jetzt erst wieder dazu mich weiter mit dem Thema zu beschäftigen.

    Ich habe den Zugriff auf das Dashboard wieder hergestellt indem ich den SSLStarter auf eine Subdomain verschoben habe. Seitdem funktioniert aber die Anzeige des RSS-Feed als Widget nicht mehr so, wie es vorher war (Verlinkungen auf die neuesten 10 Beiträge). Ich habe vermutet, dass dies noch mit dem SSL-Starter zusammenhängt und deshalb habe ich versucht den wieder auf eine ungenutzte Einstellung zu bringen, indem ich die Subdomain geschlöscht habe. An der Einstellung für den SSL-Starter hat das nichts geändert (der steht nach wie vor aktiv auf einer jetzt gelöschten Subdomain), aber so konnten dann wieder die RSS-Feeds, wenn auch nur als genereller Link und nicht auf die einzelnen Beiträge, im Widget wieder angezeigt werden.

    Übrigens, die Anzeige im 1&1 App-Center, wie oben in der Grafik, habe ich nie gehabt. SSL-Starter stand nur im 1&1 Control-Center unter SSL-Zertifikate und dort habe ich dann den SSL-Starter auch aktiviert bzw. dann später nach den Problemen auf eine Subdomain umgeleitet.

    Für einen Tipp, wie ich das korrekt hinbekomme, entweder hier (vielleicht gibt es ja noch mehr Leute die Probleme haben) oder über eine Nachricht an meine Mailadresse wäre ich sehr dankbar.

    Vielen Dank und Grüße,
    Joachim

    1. 1und1hilfe sagt:

      Hallo Joachim,

      das oben im Artikel beschriebene Feature gibt es zur Zeit nur in neuen Webhosting / Managed WP-Tarifen. Neu bedeutet in diesem Fall: Ab dem 10.05.2016 abgeschlossen.

      Viele Grüße,
      Michael, 1&1

  3. Christoph sagt:

    Ich habe auf unserer Webseite das SSL Zertifikat installiert. Die Domain https://wortmalereien.com wird jedoch als “Verbindung ist nicht sicher” (gelbes Schloss) angezeigt.

    Wenn ich mir den Unterschied zwischen HTTP und HTTPS anschaue, so sehe ich, dass bei der HTTPS Verbindung das Logo (WM_Logo_165x60.png) nicht angezeigt wird. Ferner wird die Seite nicht automatisch in HTTPS angesteuert. In Anbetracht dessen, dass bei HTTPS das Bild-Logo nicht angezeigt wird ist es OK.

    Dennoch stelle ich mir die Frage, wie können wir automatisch die Seite in HTTPS öffnen und das Logo (PNG Bild) behalten.

    Mit herzlichen Grüßen
    Christoph

    1. 1und1hilfe sagt:

      Hallo Christoph,

      genau zu diesem Thema haben wir in den letzten Tagen einen Artikel veröffentlicht: https://community.1und1.de/mixed-content-erkennen-und-entfernen/

      Was ihre Bilddatei fürs Logo angeht, so finde ich hierzu diese URL-Angabe:

      https: // s646224018.online.de/wp-content/uploads/2013/11/WM_Logo_165x60.png

      Ein Zertifikat haben Sie aber nur für Ihre “richtige” Domain, nicht für diese Standard-Subdomain. Das Ändern der Pfadangabe von http in https ist hier also nicht so einfach möglich.

      Das Logo müssten Sie richtigerweise mit dieser URL einbinden (ohne die Leerzeichen nach dem https, diese hab ich nur eingebaut, damit unser Kommentarsystem das einigermaßen sinnvoll darstellt):

      https: // wortmalereien.com/wp-content/uploads/2013/11/WM_Logo_165x60.png

      Warum Ihre Website beim Start nicht “grün” als SSL verschlüsselt angezeigt wird, liegt am oben schon erwähnten Mixed Content. Ich hab mir das mal in der Netzwerk-Analyse von Chrome angesehen. Dort finde ich dann z.B. dieses hier:

      “(index):254 Mixed Content: The page at ‘https: // wortmalereien.com/’ was loaded over HTTPS, but requested an insecure image ‘http : // s646224018.online.de/wp-content/uploads/2013/12/AndreaMaier_hp.gif’. This content should also be served over HTTPS.”

      Die Subdomain dürfte noch irgendwo in Ihrem WordPress (evtl. in der MySQL-Datenbank oder auch durch Angabe im Code einer Theme-Datei) so angegeben sein. Das sollten Sie dann entsprechend ändern.

      Viele Grüße,
      Michael, 1&1

  4. Christoph sagt:

    Hallo Michael,
    vielen herzlichen Dank für diese wertvollen Informationen.

    Das Beste wird es wohl sein, die Datenbank zu sichern und dann mit “Better Search Replace”, oder “Database Search und Replace” die fehlerhaften Links zu ersetzen. Vor allem, alle Links in HTTPS zu wandeln und dann ein Redireckt in der .htaccess zu setzen.

    Sie haben mir bestens geholfen.
    Herzliche Grüße
    Christoph

  5. Christoph sagt:

    Alles hat bestens geklappt! 🙂

    Vielen Dank!
    Christoph

    1. 1und1hilfe sagt:

      Super, das freut uns 🙂

      Sehr gern geschehen!
      Michael, 1&1

  6. Hagen sagt:

    “SSL wird automatisch konfiguriert
    Alle Anpassungen an Ihrer Domain und in WordPress übernehmen wir für Sie.”

    stimmt nicht: mixed content muss selbst entfernt werden und anschliessend zeigen die permalinks immer noch auf http, die wpconfig und die htaccess können nicht angepasst werden, weder per ftp noch per wordpress, dadurch kann auch keine automatische weiterleitung von http auf https eingerichtet werden

    1. 1und1hilfe sagt:

      Hallo Hagen,

      im Normalfall klappt das tatsächlich automatisch. Gerne prüfen und beheben wir Ihre Probleme mit dem mixed Content in Ihrer Managed WordPress Installation. Senden Sie uns dazu einfach Ihre Vertragsdaten + die WordPress URL per E-Mail an hilfe@1und1.de

      Viele Grüße,
      Michael, 1&1

  7. Stephan sagt:

    Sie erklären in Ihrem, dass es sehr einfach ist, ein managed WordPress mit SSL zum Laufen zu bringen. Kann ich irgendwo nachlesen, wie man ein WordPress, das ich manuell auf dem Server installiert habe, mit SSL zum Laufen bringt?
    Viele Grüße
    Stephan

    1. 1und1hilfe sagt:

      Hallo Stephan,

      da WordPress kein integriertes SSL-Feature hat, welches man einfach ein- oder ausschalten könnte, ist die Vorgehensweise wie bei einem Domain-Wechsel. Hier erklären wir Ihnen die einzelnen Schritte: https://hilfe-center.1und1.de/hosting/1und1-webhosting-c10085285/websites-erstellen-und-bearbeiten-c10082635/app-center-c10082695/domain-wechseln-bei-wordpress-standard-a10794733.html

      Ggf. ist es noch erforderlich, Anpassungen direkt in der MySQL-Datenbank vorzunehmen. Hierzu finden Sie hier eine Anleitung: https://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

      Viele Grüße,
      Michael, 1&1

  8. Birgit sagt:

    Hallo,

    seit rund einem halben Jahr lebe ich in dem Glauben, meine Website sei sicher, da ich SSL aktiviert hatte. Nun stelle ich fest, dass man es noch umständlich einrichten muss. Die eine Minute ist jetzt schon mindestens 250-fach abgelaufen.

    Ich habe die .htaccess im 1&1 Webexplorer gesehen. WordPress meldet mir in Abschnitt Permalinks, dass sie leider nicht writable war, deshalb solle man folgenden Code einfügen:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Den Code habe ich in eine neue Datei geschrieben (Editor). Beim Transfer mit WinSCP war die Datei offensichtlich unsichtbar, also habe ich meine neu .htaccess in das Root-Verzeichnis kopiert – in der Hoffnung, dass die alte Datei überschrieben wird. Denn Umbenennen, Sichtbarmachen, Runterladen und Verschieben ging genausowenig wie das Öffnen.
    Mit Better Search Replace habe ich alle http:// in https:// umgewandelt, und zwar vor und nach dem FTP-Transfer.
    Jetzt läuft die Sache immer noch nicht und ich bin ABSOLUT ratlos.

    Haben Sie noch einen Tipp?

    Viele Grüße
    Birgit Bruder

    1. 1&1 Hosting Support sagt:

      Hallo,

      wie ich sehen konnte, konnten die Kollegen bereits helfen. Im Managed Mode gibt es leider keinen Schreibzugriff auf die .htaccess-Datei, weshalb hier zum Standard Mode gewechselt werden muss. Damit ist es dann kein Problem mehr.

      Viele Grüße
      Martin, 1&1

  9. In meinem Vertrag ist noch ein SSL-Zertifikat frei. Im App-Center wird aber nicht die hier beschriebene Möglichkeit angezeigt, dieses zu aktivieren. Können Sie weiterhelfen?

    1. 1und1hilfe sagt:

      Hallo Thomas,

      die oben im Artikel beschriebene Funktion gibts nur bei Managed WordPress-Installationen. Da Sie sie Standard-Variante installiert haben, ist die Umstellung auf https nun wie bei manuellen WordPress-Installationen üblich vorzunehmen. Das läuft in WordPress genauso ab wie ein Domain-Wechsel. Hier finden Sie u.a. weitere Infos dazu: https://codex.wordpress.org/Changing_The_Site_URL
      https://hilfe-center.1und1.de/hosting/1und1-webhosting-c10085285/websites-erstellen-und-bearbeiten-c10082635/wordpress-typo3-joomla-drupal-magento–c10085408/websites-automatisch-installieren-1und1-app-center-c10082695/domain-bei-wordpress-standard-aendern-a10794733.html

      Viele Grüße,
      Michael, 1&1

  10. Martina Kink sagt:

    Hallo,
    ich habe eine SSL Zertifikat, das noch bis Ende des Jahres gültig ist. Obwohl es aktiviert ist, sagt mir Firefox, dass meine Seite nicht sicher ist. Wir haben die alte Website durch eine neue ersetzt – beide in WordPress mit Woocommerce als Shop theme. Kann es daran liegen und was kann ich tun, dass die Verknüpfung funktioniert?
    Für einen Tipp wäre ich dankbar.
    Gruß
    Martina

  11. Hallo Michael,

    ich habe gerade die oben stehenden Kommentare gelesen und ehrlich gesagt habe ich gerade ein schlechtes Gefühl auf ssl umzustellen. Ich habe bei Euch die Manged WordPress Variante aktiviert. Die ssl Verschlüsselung der Domain ist beantragt, wer stellt mir sicher das hier alles reibungslos funktioniert. Ich habe Monate an der HP gearbeitet, ich kann es mir nicht leisten das hier etwas schief läuft. Bitte um einen Rat.

    Viele Grüße
    Stefan

  12. Hallo Michael, Ergänzend zu meinem Beitrag, ich habe das SSL Buisness Zertifikat beauftragt, funktioniert wir oben beschrieben, oder muss ich Bedenken haben.

    D+VG
    Stefan

    1. 1und1hilfe sagt:

      Hallo Stefan,

      beim SSL Business-Zertifikaten bedarf es noch einer zusätzlichen Authentifizierung bei der Zertifizierungsstelle. Daher sollten Sie in jedem Fall erst dann auf “SSL aktivieren” klicken, wenn der komplette Einrichtungsprozess für das Zertifikat abgeschlossen wurde. Die einzelnen Schritte erklären wir Ihnen hier: https://hilfe-center.1und1.de/hosting/ssl-zertifikate-c10082656/einrichtung-c10085373/von-1und1-verwaltetes-ssl-zertifikat-einrichten-1und1-ssl-business–ssl-business-plus-a10795655.html

      Viele Grüße,
      Michael, 1&1

  13. Liebes 1&1-Team,

    löblich, dass Ihr die SSL-Verschlüsselung hervorhebt und aktiv bewirbt.

    Aber warum schaltet Ihr sie jedesmal wieder ab (zumindest bei meiner Webpräsenz), wenn ein WP-Update aufgespielt wird, wie just wieder bei WP_4_9_3 passiert.

    Herzliche Grüße
    Jochen

    1. 1und1hilfe sagt:

      Hallo Jochen,

      absichtlich passiert das natürlich nicht, das HTTPS-Schema bleibt in der Regel auch bei einem Update einer Managed WP-Installation erhalten.

      Bei älteren Safe Mode-Installationen war SSL eigentlich noch gar nicht supportet- daher könnte es hieran liegen. Bei echten Managed WordPress-Installationen kommt dies aber wie gesagt nicht vor.

      Viele Grüße,
      Michael, 1&1

  14. Dedo sagt:

    Meine SSL Verschlüsselung hat nicht funktioniert, und dann bin ich auf eine Seite verwiesen worden, wo ich dafür was bezahlen soll. Ich denke die SSL Verschlüsselung ist kostenlos. Was ist das denn?

    1. 1und1hilfe sagt:

      Hallo Dedo,

      in jedem 1&1 Hosting-Vertrag ist ein kostenfreies SSL-Zertifikat für 1 Domain (mit und ohne www.) oder Subdomain enthalten.

      Wenn Sie dieses evtl. bereits für eine andere Domain verbraucht haben, wird Ihnen jedes weitere Zertifikat zum Kauf angeboten.

      Viele Grüße,
      Michael, 1&1

  15. Stefanie sagt:

    Hallo,

    ich gabe das Starter Set für WP. Allerdings erscheint nach aktivierung des SSL-Zertifikat immer noch das meine Seite nicht uneingeschränkt sicher ist. Wie kann das sein?

    1. 1und1hilfe sagt:

      Hallo Stefanie,

      im Prinzip ist alles, was Sie in Ihrer WordPress-Seite einfügen als Link in der MySQL-Datenbank hinterlegt. Hier trägt unser Tool normalerweise alles auf “https:”-Links um. Dies scheint im ersten Versuch bei Ihnen nicht direkt geklappt zu haben – oder Plugins verhinderten dies.

      Wie ich sehe, konnte Ihnen hierzu aber bereits unsere Hotline weiterhelfen – auf Ihrer Website konnte ich keine gemischten Inhalte (also https und http) mehr sehen. Es sieht mittlerweile alles sauber aus 🙂

      Viele Grüße und weiter viel Freude beim Bloggen!

      Michael, 1&1

      1. Hallo Michael,

        ich habe habe eine neue HomePage „www.diekleinenzwergetuebingen.de“ aufgesetzt, SSL habe ich aktiviert. Allerdings geht die Verschlüsselung nicht, könntest du mir bitte ein Tipp geben, woran es liegt.

        Danke und Gruß
        stefan

        1. Hallo Michael,
          ich habe die Fehler gefunden, es lag an ein paar urls innerhalb der Homepage.

          Danke und Gruß
          Stefan

  16. Benedikt sagt:

    Die automatische Konfiguration bei meiner managed WordPress Seite hakt bei mir leider an einer Stelle. Es funktioniert alles bis auf die automatische Weiterleitung auf die HTTPS-Seite. Über einen “http://…” Link komme ich noch immer auf die ungesicherte Version.

    Was kann ich tun?

    1. 1und1hilfe sagt:

      Hallo Benedikt,

      im vorliegenden Fall scheint der oben beschriebene Automatismus nicht zu klappen.

      Bitte aktivieren Sie daher zunächst das SSL-Zertifikat für die betreffende Domain wie hier beschrieben: https://hilfe-center.1und1.de/hosting/article/10795340

      Testen Sie dann im Anschluss, ob der https-Aufruf an sich fehlerfrei funktioniert. Wenn dies der Fall ist, den “SSL aktivieren”-Button bei Ihrer Managed-Installation klicken und den weiteren Schritten folgen.

      Viele Grüße,
      Michael, 1&1

  17. Louisa Bekker sagt:

    Hallo!

    ich habe vor ein paar Monaten (nach anfänglichen Schwierigkeiten von seitens 1und1) erfolgreich das SSL-Zertifikat für meine Managed WordPress Seite einrichten können.

    Jetzt ist mir am Wochenende aufgefallen, dass die komplette Seite nicht mehr https als Standard verwendet, sondern sich wieder auf http umgestellt hat! Das wird mir auch in den WordPress Einstellungen bestätigt (Meine URL geht wieder mit http://.. los)!

    Ich habe deswegen jetzt schon mehrfach beim Support angerufen und jedesmal eine andere Geschichte erzählt bekommen, mit dem Endresultat, dass es angeblich bis ende des Tages wieder funktionieren würde. Tut es aber immer noch nicht! Ich weiß langsam echt nicht mehr was ich tun soll, da mir nicht die Möglichkeit besteht mit jemandem in Kontakt zu treten, der weiß was hier zu tun ist!

    Um eine Antwort und eine Lösung wäre ich also sehr dankbar!

    Gruß,
    Louisa

    1. Louisa Bekker sagt:

      Als Anhang:

      “Mixed Content entfernen und ersetzen (WordPress):
      Im Prinzip ist das Problem in WordPress einfach in zwei Schritten zu lösen:
      Alle HTTP-Links in der WordPress-Datenbank in HTTPS-Links umwandeln.
      Einen permanenten 301 Redirect von HTTP auf HTTPS im Webserver einrichten.”

      Das ist ein Ausschnitt aus einem 1und1 Artikel zum Thema Mixed Content. So wie ich es verstehe, ist genau das mein Problem und müsste behoben werden (ich habe genau dieses Thema auch beim Support angesprochen und dieser hat mir versichert, dass er davon nichts wüsste).

      1. 1und1hilfe sagt:

        Hallo Louisa,

        ich spekuliere ungern ohne die Installation zuvor gesehen zu haben. Ich schaue mir das gerne mal für Sie an, senden Sie mir dazu bitte eine E-Mail mit Ihren Kundendaten + Domain-Name an hilfe@1und1.de

        Vielen Dank und Grüße,
        Michael, 1&1

        1. Louisa Bekker sagt:

          Vielen Dank für die schnelle Antwort! Email geht sofort raus!

  18. Jasmin sagt:

    Hallo zusammen,

    ich habe über die 1&1 Plattform das SSL Zertifikat aktiviert aber leider wird meine Seite als “nicht sicher” angezeigt. Könnten Sie das bitte richtigstellen? Ich möchte ungern selber an die Codes.

    danke und liebe Grüße

    1. 1und1hilfe sagt:

      Hallo Jasmin,

      wir kommen an die entscheidenden Punkte Ihrer Standard WordPress-Installation nicht ran. Daher müssten Sie das schon selbst ändern.

      Letztlich kommt die Änderung der Seite von http auf https einem Domain-Wechsel gleich. Hierfür bieten wir Ihnen eine passende Anleitung im 1&1 Hilfe-Center: https://hilfe-center.1und1.de/hosting/1und1-webhosting-c10085285/websites-erstellen-und-bearbeiten-c10082635/wordpress-typo3-joomla-drupal-magento–c10085408/websites-automatisch-installieren-1und1-app-center-c10082695/domain-bei-wordpress-standard-aendern-a10794733.html

      Viele Grüße,
      Michael, 1&1

      1. Jasmin sagt:

        komisch, wenn ich aber über die SSL Zertifikate verwalten gehe steht dort: “Das SSL-Zertifikat ist aktiviert und Ihre Domain ist sicher.”

        1. 1und1hilfe sagt:

          Genau, das stimmt auch 🙂 Nur müssen Sie jetzt noch der Anwendung beibringen, das Zertifikat für den Aufruf per “https” (statt nur “http”) auch zu nutzen. Das können wir nur im Managed Modus für WordPress für Sie verwalten (siehe im Artikel oben). Da es sich bei Ihnen aber um einen “normale” Standard-Installation handelt, ist das von Ihrer Seite aus zu konfigurieren.

          Viele Grüße,
          Michael, 1&1

  19. TK sagt:

    Ich habe ein SSL-Zertifikat erhalten und auch eingerichtet / aktiviert. Für meine Subdomains genealogie.saecula.de funktioniert die Umleitung auf https: dank htaccess auch. An der fehlenden Aktivierung liegt es also nicht.
    Für die Hauptseite saecula.de mit WordPress erfolgt aber keine Umleitung von http auf https. In die vorhandene htaccess kann ich anscheinend nicht schreiben. Schreibgeschützt, da Managed Modus?
    Bitte um entsprechende Einstellung / Umleitung

  20. Roman Klonek sagt:

    Hallo,
    ich habe versucht umzustellen.
    Obwohl in meinem Status nun steht: “Das SSL-Zertifikat ist aktiviert und ihre Domain ist sicher” steht, steht im der Browserzeile immer noch “Verbindung ist unsicher”.
    Warum?

    1. 1und1hilfe sagt:

      Hallo Roman,

      Sie haben gemischte Inhalte (“mixed Content”) auf Ihrer Website. Manche Inhalte werden via “https” geladen, manche aber noch mit “http”.

      Zu diesem Thema haben wir schon mal einen Artikel mit Tipps und Tricks veröffentlicht. Hier werden Sie fündig: https://community.1und1.de/mixed-content-erkennen-und-entfernen/

      Viele Grüße,
      Michael, 1&1

  21. Guido sagt:

    Hallo 1&1, auf meiner Webseite ist das SSL-Zertifikat aktiviert. Leider finde ich aber beim Einloggen keinen SSL aktivieren-Button, der oben angezeigt wird. Und die Seite ist noch immer nicht auf https. Was muss ich jetzt tun, damit das passiert?

    1. 1und1hilfe sagt:

      Hallo Guido,

      Sie haben sich bei der WordPress-Installation für den Standard-Modus entschieden. Damit unterscheidet sich die Vorgehensweise nicht von einer ganz normalen WordPress-Installation, die Sie bei wordpress.org herunterladen können.

      Sie müssen Ihrer WordPress das HTTPS als Domain-Änderung beibringen. Machen Sie also in Ihren WordPress-Einstellungen für die Site URL und Home URL aus “http” “https”. Danach sollten Sie noch erzwingen, dass ein Aufruf über http automatisch auf “https” weiterleitet. Dies klappt über eine Weiterleitungsregel in der WordPress .htaccess-Datei.

      Fügen Sie dort den folgenden Befehl an einer sinnvollen Position ein:

      RewriteCond %{HTTPS} off
      RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

      (In der regulären .htaccess von WordPress nach der Zeile RewriteEngine On)

      In manchen Fällen kann es noch notwendig sein, die URL in der MySQL-Datenbank anzupassen. Hierzu hilft Ihnen z.B. dieser Artikel: https://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

      Alternativ gibt es auch Plugins, die Ihnen die Arbeit in der MySQL-Datenbank etwas vereinfachen. Aber auch da sollten Sie sich nur ranwagen, wenn Sie sich mit der Thematik einigermaßen sicher fühlen.

      Viele Grüße,
      Michael, 1&1

  22. Jutta Str. sagt:

    Hallo,
    auf unsere Seite ist WordPress Managed mit SSL Verschlüsselung. Wenn man auf die https URL geht, funktioniert das auch und es wird im Browser das grüne Schloss angezeigt. Leider funktioniert aber nicht die Weiterleitung von der http URL aus und die Seite wird als unsicher angezeigt. Durch Suchen vermute ich jetzt, dass man die .htaccess-Datei um diese Umleitung ergänzen müsste?
    Geht das über FTP? Über den Webspace Explorer konnte ich eine abgeänderte .htaccess-Datei nicht hochladen, da kam eine Fehlermeldung.

    Für den Code in der .htaccess-Datei habe ich zudem zwei Varianten gefunden, welche ist die Richtige?

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.yoursite.com/$1 [R,L]

    oder

    RewriteEngine On
    RewriteCond %{SERVER_PORT} !=443
    RewriteRule ^(.*)$ https://ihredomain.de/$1 [R=301,L]

    Oder muss man erst von Managed auf Standard umstellen? Hat das noch andere Auswirkungen auf das WordPress?

    Viele Grüße
    Jutta

    1. 1und1hilfe sagt:

      Hallo Jutta,

      sofern Sie für Ihre Domain ein SSL-Zertifikat aktiviert haben, sollte die Managed WordPress-Installation die Weiterleitung auf HTTPS automatisch übernehmen. Eine .htaccess ist dabei nicht notwendig.

      Hier scheint aber etwas bei Ihrer Installation nicht zu stimmen. Unser Support schaut sich das gerne genauer an – melden Sie sich dort einfach zur Überprüfung:

      https://kontakt.1und1.de/

      Viele Grüße
      Michael, 1&1

  23. Dennis Prinz sagt:

    Hallo Supportteam,

    ich bekomme auf diversen Endegräten die Meldung
    SSL_ERROR_RX_RECORD_TOO_LONG

    ist allerdings nicht überall so, wie sehen die nächsten schritte zur behebung aus?

  24. 1und1hilfe sagt:

    Hallo Dennis,

    diesen Fehler bekam ich gerade auch auf einem iOS-Gerät, mittlerweile wird die Seite aber sauber geladen. Scheint hier einfach der SSL-Aktivierung ein wenig gedauert zu haben.

    Bitte testen Sie es nochmal mit geleertem Browser-Cache an den jeweiligen Endgeräten.

    Viele Grüße
    Michael, 1&1

  25. Michael sagt:

    Hallo,

    leider erhalte ich auf meine Emails an den Kundenservice keine Antwort und auch telefonisch komme ich einfach nicht durch. Darum auf diesem Weg:

    Ich habe ein SSL Starter Plus Zertifikat für meine Domain und Subdomain aktiviert. Laut Domain Center ist es auch aktiv, dort ist das grüne Schloss neben meiner Domain zu sehen.

    Im Internet wird jedoch nur bei meiner Subdomain https und das grüne Schloss angezeigt, meine Domain ist jedoch nicht gesichert, es wird nicht von http zu https weitergeleitet.

    Im Dashboard meiner WordPressseite kann ich unter Einstellungen/Allgemein die URL nicht ändern, dort steht, dass ich sie im 1und1 App Center anpassen kann. Dort finde ich allerdings keine Option sie auf https zu ändern.

    Wird die Umleitung von http zu https irgendwann automatisch von 1und1 gesetzt? In die htaccess-Datei kann ich keinen Umleitungscode einfügen, weil es sich um eine Safemode Installation handelt. Das würde ich eigentlich auch gerne so beibehalten.

    Danke für eine Info.

    Grüße
    Michael

    1. 1und1hilfe sagt:

      Hallo Michael,

      die URL-Änderung auf https haben wir schon mal für Sie umgesetzt.

      Was nun noch fehlt, ist das Erzwingen von https beim http-Aufruf. Darum kümmern wir uns jetzt noch. Sobald dies gelöst ist, melden wir uns bei Ihnen.

      Viele Grüße
      Michael, 1&1

  26. Gabi sagt:

    Ich habe exact das gleiche Problem wie Michael über mir. Den Kundenservice kann ich telefonisch nicht erreichen, da kann ich anrufen wann ich will.

    Könntet ihr das nicht für uns Kunden umstellen, denn bei Managed WP können wir das ja nicht selbst machen?

    1. 1und1hilfe sagt:

      Hallo Gabi,

      wie gesagt sollte das eigentlich automatisch passieren – in Ihrem Fall leider nicht. Wie auch bei dem anderen Michael gebe ich Ihren Fall direkt an die Entwickler weiter.

      Wir melden uns.

      Viele Grüße
      Michael, 1&1

  27. Auch ich habe das Problem mit der Umstellung wie gabi und michael und kann den Kundendienst nicht erreichen.

    1. 1und1hilfe sagt:

      Auch Ihren Fall lassen wir klären.

      Viele Grüße
      Michael, 1&1

    2. 1&1 Hosting Support sagt:

      Hallo Berthold,

      wir haben Ihre Seite auf SSL umgestellt. Danke, dass Sie Geduld mit uns hatten.

      Viele Grüße
      Martin, 1&1

  28. Martin sagt:

    Wir haben WordPress über das App-Center eingerichtet und möchten nun ein SSL-Zertifikat aktivieren. Leider existiert in unserem Verwaltungsbereich kein Button “SSL aktivieren”. Daher bin ich den Weg über den Menüpunkt “SSL-Zertifikate” gegangen und habe für die entsprechende Domain ein SSL-Zertifikat eingerichtet. Nun wird im App-Center auch ein grünes Schloss angezeigt. Die Website wird jedoch weiter über http:// aufgerufen, es erfolgt auch keine Weiterleitung und auch im WordPress-Backend ist die Domain weiter nur mit http:// angegeben. Wird die Seite manuell über https:// aufgerufen, wird jedoch bereits ein gültiges Zertifikat ausgegeben. Was muss ich tun, damit die Seite nur noch über http:// aufgerufen wird und sich auch die WordPress-Domain ändert? Vielen Dank!

    1. 1und1hilfe sagt:

      Hallo Martin,

      in diesem konkreten Fall können Sie nichts tun – wir übernehmen ab hier.

      Wir lassen Ihren Fall klären.

      Viele Grüße
      Michael, 1&1

      1. Martin sagt:

        Vielen Dank für die schnelle und zielführende Unterstützung. Es scheint alles geklappt zu haben!

  29. Hallo,
    ich habe ebenfalls das gleiche Problem wie Michael und Gabi,

    Das SSL Starter Plus Zertifikat für meine Domain ist aktiviert. Laut Domain Center ist es auch aktiv, dort ist das grüne Schloss neben meiner Domain zu sehen.

    Im Internet wird jedoch meine Domain nicht gesichert, es wird nicht von http zu https weitergeleitet.

    Im Dashboard meiner WordPressseite kann ich unter Einstellungen/Allgemein die URL nicht ändern, dort steht, dass ich sie im 1und1 App Center anpassen kann. Dort finde ich allerdings keine Option sie auf https zu ändern.

    Viele Grüße, Claudia

    1. 1und1hilfe sagt:

      Hallo Claudia,

      Sie ahnen es sicher schon:

      Auch Ihren Fall lassen wir klären.

      Viele Grüße
      Michael, 1&1

  30. Heiko sagt:

    Mit meiner Domain heikole-art.net habe ich das gleiche Problem wie Gabi und Michael über mir.
    Ich bitte um Unterstützung bei der Problemlösung.

    1. 1und1hilfe sagt:

      Auch Ihren Fall lassen wir klären.

      Viele Grüße
      Michael, 1&1

  31. Gabi sagt:

    Hallo Michael,

    ich möchte mich an dieser Stelle Recht herzlich bedanken. Es wurde alles zu meiner vollen Zufriedenheit umgestellt 🙂 nun funktioniert alles wie gewünscht.
    Dieses Feedback wollte ich einfach zum Abschluss noch hierlassen. Dankeschön

  32. Oliver sagt:

    Hallo,
    auch wir haben das gleiche Problem mit der Weiterleitung von http:// auf https://
    Alles nach Vorschrift installiert. SSL-Zertifikat, Zertifikat zugewiesen. Grünes Schloss wird im App-Center vor der Domain angezeigt. Weiterleitung auf https:// oder verschlüsselter LogIn zum WordPress Admin funktioniert nicht.

    VG Oliver

    1. 1&1 Hosting Support sagt:

      Hallo Oliver,

      danke für den Beitrag. Wir kümmern uns schnellstmöglich darum, dass das SSL für deine Webseite funktioniert und melden uns wieder.

      Viele Grüße
      Martin, 1&1

  33. Michael sagt:

    Hallo 1&1-Michael,

    vielen Dank für den schnellen Support, echt top!

    Jetzt funktioniert alles 🙂

    Grüße
    MIchael

  34. Patrick sagt:

    Hallo Kundenbrtreuung,

    auch wir haben bei unseren beiden Verträgen das Problem, dass das SSL-Zertifikat nicht im “safe-mode” aktivierbar ist. es kann nicht auf https geändert werden. Ich hänge schon seit 50 Minuten in der Warteschleife des Kundendienstes.

    MfG,
    Patrick

    1. 1und1hilfe sagt:

      Hallo Patrick,

      wir haben das Problem für Sie behoben. Die Seite ist ab sofort durchgängig via https zu erreichen.

      Viele Grüße
      Michael, 1&1

  35. Melanie sagt:

    Leider habe ich dasselbe Problem wie meine Vorredner – SSL-Zertifikat ist eingerichtet und wird als aktiviert angezeigt, die Website ist jedoch nur über http:// zu erreichen und wird als “nicht sicher” angezeigt. Könnten Sie dies bitte ebenfalls überprüfen lassen?

    Mfg

    1. 1und1hilfe sagt:

      Hallo Melanie,

      da es sich in Ihrem Fall nicht um Managed WordPress handelt, können und müssen Sie das selbst einstellen.

      Eine gute, ausführliche Anleitung dafür finden Sie z.B. beim netten Theme-Entwickler-Team von Elmastudio:

      https://www.elmastudio.de/wordpress-webseiten-auf-https-umstellen-leicht-gemacht/

      Viele Grüße
      Michael, 1&1

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *